A catch all category for posts that are neither specific to a Microsoft technology which has its own dedicated category or posts that aren’t based on a Microsoft technology, as rare as those are.

Heatmiser Touchscreen Thermostat Review

As part of one of the many DIY projects at home at the moment, me and the wife are preparing to get our hallways, stairs and landings plastered; the final piece of our house decoration project, no less than five years after buying our first house together.

The house was originally equipped with warm air circulation heating, however about two years before we moved into the house, the previous owners had central heating fitted. As with any standard central heating install, the thermostat and timer system was basic and left a lot to be desired, with the timer controls located upstairs, tucked away with the boiler and wiring centre, and the thermostat being a standard twist dial model where to engage the heating was a process of trial and error twisting the dial until you heard the vague click of engagement.

Being a technophile and wanting something a little more for our lifestyle or technology, I discovered a company called Heatmiser which make a range of amazing looking and functioning slimline and touchscreen thermostats. I purchased their PRT-TS touchscreen model, which you can see here on their website (

The unit is flush mounted, so meant I had to spend some time channelling out the wall to recess a 35mm patress back box, but this was a good thing as it gave me the chance to remove the plastic cable trunking which the previous owners had used to ‘hide’ the wiring for the old model which was surface mounted, along with re-positioning it away from the kitchen door where the previous owners had mounted it directly against which just looking unsightly.

In our wiring configuration, there is a small gotcha, which I originally misread in the wiring diagram, which is that you may require a short piece of Live coloured wire (if you’re doing it properly) to bridge between the Live and the A1 terminal interfaces. The A2 terminal connects to the yellow call for heat wire, however the switch to engage the call for heat is across the A1 and A2 terminals. Bridging the Live and the A1 terminals allows current to flow through the call for heat switch, and hence allowing the heating to be engaged. In my initial wiring of the unit, the unit was functional, however heat wasn’t being called for this reason, but bear in mind that depending on your wiring configuration, this may not be required.

The advantages to this setup are amazing. The new thermostat actually controls the entire heating timings and temperature, so to have it function correctly, you actually configure the timer unit in the wiring centre for permanent on mode and let the thermostat do the rest, making the control of it more friendly as it’s in the main body of the house. The new unit is energy saving trust approved and claims to be able to save up to 10% on your heating bills due to two key features. One is the accuracy as this unit is accurate to +/- 1oC verses a standard unit which is about 2-3oC and the second feature is Optimum Prestart.

Unlike conventional thermostats where you have to incorporate an element of warm up time in your programming so that the house is warm when you wake up, this unit calculates the exact amount of time to warm the house to the required temperature and engages the heating automatically at this time to ensure that you reach the required temperature by the time you set. This feature is disabled by default, but entering the Feature configuration mode on the touchscreen LCD allows you to enable it and specify whether to allow the unit one or hours hours to perform Optimum Start functions.

The finish of the product is really nice. I opted for the silver bezel, and with it’s blue backlight LCD which only illuminates when you touch the screen looks really modern and 21st century, but it’s also available in white and brass finishes too.

The unit has another feature called Frost Protection Mode, which when enabled by default allows you to configure a temperature, which when breached will automatically engage the heating outside of your normal comfort levels as Heatmiser call them, or timer settings as you would normally call them. This level can be set low to prevent accidental heating engagements, but is valuable as it helps maintain a safe temperature in the house whilst helping to prevent any pipe freezing etc in deep cold during winter. This is another way in which it helps reduce your bills as it means that firing up the heating for short five minute bursts during normal daytime hours to maintain a core temperature means you actually need the heating engaged for less time during your comfort times because the house is already closer to that comfort temperature.

Although I’m yet to see the real effectiveness of the unit as it’s currently summer, I’m sure it’s going to be great. The lock function for the LCD means that the kids can’t change any of the settings without unlocking it, which requires a key press for 10 seconds to disengage and the Hold function allows you to boost the temperature if you are feeling a bit cold one evening and it allows you to specify a hold time so that you don’t forget to turn the thermostat down again afterwards.

The timer programming is simple yet concise. I’ve set our unit to 7 day mode due to our lifestyle which means you get four settings for each of the 7 days, and for each event (Wake, Leave, Return and Sleep) you can specify a temperature, so you no longer have to run to the thermostat in the evening to turn it up because you want it warmer in the eventing that you do in the mornings before work.

The Heatmiser line actually includes many other products, some of which really interest me. One is a unit identical in looks to ours, but also allows control of the hot water timings, which then completely removes the need for a timer in the wiring centre, however the setup for our current heating system doesn’t permit this model. Our unit is a 230v model due to our current system, however they have a range of 12v units for more modern low voltage heating, and they also have a range of network thermostats which allows you, when connected to a Network Wiring Centre to link multiple thermostats for operation of split zone heating from one of many units, and control all of the units from a single unit, or even control the heating remotely via a web application or SMS message. I hope that in our next house, years down the line I get the opportunity to use some of these other products. I would love to be able to use the Heatmiser web application as part of a Media Center interface via a plugin so that you can adjust the heating from your 10ft view.

Come the winter I’ll post another review of how the unit actually performs at managing the heating bill and temperature maintenance, but so far, the outlook is good.

Outlook 2010 Social Connector ProgID for Facebook

Today, I was investigating the management and control of the Outlook Social Connector via Group Policy, using the Office 2010 ADM/ADMX files from Microsoft.

Two of the settings of interest for the Outlook Social Connector are the ability to control which social connectors are displayed, and which are automatically loaded without user interaction. Whilst looking online, a Microsoft Forum thread appeared in my results with the ProgID for some of the available connectors, however they were missing a big one – Facebook.

Looking in the HKEY_CLASSES_ROOT registry hive on my machine, where I have the Facebook connector installed, I found it, so here is a list of the currently available Outlook Social Connector ProgIDs which can be used (semi-colon seperated) in the Group Policy Management Console to configure the behaviour.

SharePoint – OscAddin.SharePointProvider
SharePoint –
LinkedIn –
MySpace –
Windows Live Messenger – OscAddin.WindowsLiveProvider
Facebook – OscAddin.FacebookProvider
Facebook – OscAddin.FacebookProvider.1

I hope this helps you all.

So Long, So Busy

It’s been quite a while since I’ve posted anything and for that I am disappointed, however I do have just cause.
Since my last post, me and the wife Nicky have been working the Cambridge Weight Plan and in one week I lost 10lb which is amazing. We’ve got Nicky’s Dad over this week helping us with some lose ends of DIY in the house too, so my evenings are packed with DIY work.

Back in the land of tech, I’ve been busy on a MIMEsweeper for SMTP training course, a Websense training course, and working feverishly hard on System Center Configuration Manager and Exchange. I’m hoping I’ll be coming out with a couple of posts soon on these subjects, along with some bits on Windows Home Server 2011.

WordPress Development – functions.php

As I travel down the road of WordPress theme development, I have discovered many things.

A problem that has been hurting me for the last week at least as I develop the new theme is errors I would occasionally receive, which would read Cannot modify header information – headers already sent. For me as a non-programmer, this didn’t really mean an awful lot, and trawling the WordPress support forum didn’t help me hugely as I didn’t understand some of the lingo being used.

I had a starting point, which was my functions.php file. This filename was referenced in the errors, with a line number however upon inspection of that line, I couldn’t see a fault, so I looked elsewhere.

This evening, I compared my functions.php file to that of the TwentyTen theme which ships with WordPress 3.1, and I noticed something interesting. My functions.php file used multiple PHP statements opened and closed as needed, however the TwentyTen functions.php file only had a single set of PHP tags, opening at the start of the file and closing at the end, with each of the functions contained within it.

When I looked back at my file, I saw that the line indicating the error was in fact a closing PHP tag.

This post is more to serve as reference for other newbies out there trying to develop your first WordPress theme. Make sure that your functions.php file is a single PHP statement from start to finish with no leading or trailing line breaks or spaces. For me, this problem caused PHP errors when trying to modify Widgets in the admin interface, configure Plugins, manage the Theme settings and also stopped RSS and XMLRPC from working, so it’s a pretty big issue.

VMware vSphere 4.1 and VCP Web Links

Having just finished the course for vSphere 4.1 today, it’s going to be all hands on deck revising this stuff for VCP for the next week or so. Here is a list of useful links for vShpere and ESX/ESXi related knowledge which will liekyl help others along with myself in my quest to obtain VCP.

I will be updating this list on an on-going basis with all of the resources I come across.

Lastly, I cannot and will not vouch for any of these sites. These are merely just sites I have found to be useful for me.

A Busy Week at Home and Work

As the title suggests, its a busy week this week all round. On Monday, I started the five day journey on the road to VCP while I attend the VMware vSphere 4.1 course with Gloval Knowledge, and with VMware currently running their own version of Microsoft Second Shot, hopefully I can have a chance if sitting the exam soon.

The wife, Nicky, Sat her final exam for her foundation course, Access to Higher Education for Midwifery, which means she now has the nervous wait to find out her final graded.

Me personally, I went to the doctors yesterday about my ongoing knee problems post-running and have now been referred to a physiotherapist for possible treatment.

As I write all this from my Windows Phone WordPress application, sitting in the car while Nicky runs into Tesco, we are about to go out for dinner with the girls to celebrate Layla’s birthday with another family, Gary and Amy and Joe’s birthday too.

The Blog is Back

For anyone who frequents my blog, you may have noticed it’s been offline for a couple of weeks.

I recently moved to a new server with my current hosting provider, and I took this opportunity to seperate a forum I run and the blog into their own seperate MySQL databases. Unfortunatly the blog had some issues, which today turned out to br a typo’d database username. We live and learn 🙂

Now that the blog is back, I’ve taken the liberty of upgrading to the latest version of WordPress. I’ve also decided that my old theme was looking tired as I do about every six months or so. As you will see, I’ve switched to the new TwentyTen theme that’s included in the new version of WordPress. This is only temporary while I make my new theme, which is going to be one I saw by Touchality based on a Windows Phone 7 Metro UI.
For the record, this is also my first ever post from the Windows Phone 7 WordPress application.

The Blog….Fixed

So it seems that the blog has been offline for about three or four weeks without my knowledge.

The only thing that actually led me to the problem was when logged into LinkedIn last week, I saw that the site wasn’t able to pull my RSS feed.

After much investigation and troubleshooting with the PHP side of things, it turns out that a problem with the hosts MySQL database engine caused one of the tables to become dirty and needed repairing.

Soon, I’ll be moving the blog to a new dedicated MySQL database as it currently shares its database with another product, Simple Machines SMF Forum, however I’ve just been given some extra databases from the host for gratis.

A New Breed of Blog

As time goes by, I feel more and more integrated into the Primark collective, getting my teeth into more new and exciting things. As time goes by, I foresee this blog evolving somewhat, not in its purpose, but in content, as I am exposed more to Exchange 2007 and likely 2010 in the future, SharePoint 2010 and the System Center family including Operations Manager, Configuration Manager and probably Service Manager and Data Protection Manager around the corner too.

I hope you enjoy the new material as and when it arrives.


The Day the Logitech Harmony One Works

We’ve been lucky enough to have a Logitech Harmony One touchscreen multifunction remote control for little over a year now and it’s safe to say that it is probably the best amount money you could spend on your TV and front room electronic devices purely for it’s power and potential and the Logitech software albeit a little cumbersome and slow has enough options and features to keep anyone satisfied – Anyone but me.

At home, we have a Samsung LE40R88BD which is about two years old now. Ever since I configured the Harmony for our TV there has been a problem – It doesn’t switch between inputs properly.

In its efforts to be intelligent, the TV skips over some inputs when they are determined to be off but this isn’t so for the entire suite of inputs, so HDMI for example is skipped, while the SCART inputs or the Component is not skipped over meaning that the Harmony has always had problems getting you to the right channel for the correct viewing device.

When at Nicky’s dads house recently and adjusting his Harmony setup for him, I noticed his remote Harmony configuration for his newer Samsung LE40A686M1F gave him access to direct input buttons such as HDMI 1, 2 and so forth which made me very jealous because his remote worked exactly how it is supposed to.

About three months ago, I sat on the remote after one of the children hid it under our beanbag and needless to say, the screen took the brunt of my weight. The touchscreen still works, but you cannot see about two thirds of the display meaning I am the only person in the house able to use these buttons purely through memory of their position.

I got an Xbox 360 for Christmas, which, with built-in infra-red and Media Center Extender support meant I would need to add this to the Harmony, however this gives me a problem. If we can’t see the screen how are we going to see the new buttons and this could cause a problem for channel switching also.

I decided to perform an experiment. I added the model code for Nicky’s dads TV set to our remote as a second TV and didn’t make it part of any of our activities configured on the remote, and I memorised the position of the HDMI input buttons. When I took to our TV with these buttons, to my surprise the commands were received by the TV and they worked.

I’ve now since removed our original TV from the Harmony configuration and replaced it in all of the activities with Mick’s model TV meaning that the Harmony now takes us directly to the correct input for each activity and also allows me to control the Xbox 360.

The lesson to be learnt: Although the Harmony software gives you excellent control over your devices, don’t always assume it’s right, and experiment from time to time.