Internal Speaker Stops Working on Nokia Lumia 925

So today I had a weird issue. The internal speaker on my Nokia Lumia 925 stopped working. When making calls, the third party could hear me but I could not hear them. If I set the phone to loudspeaker then I could hear them just fine though so the problem was clearly the internal speaker only. I knew that their shouldn’t have been anything wrong with the phone as such as I had used it the evening previously to make a call.

I looked on the Nokia Support site and the recommendation was to perform a soft reset on the phone, holding the Power and Volume Down button for ten seconds. This didn’t work and after the reset, the phone still wouldn’t give me any audio so the next step was to RMA the phone back to Nokia.

I tried a web search which I was expecting to be fruitless and it was largely, except for one article, a number of pages through the results, past some people complaining about other audio problems with the Lumia 925. A user suggested plugging and unplugging something from the 3.5mm headphone jack to make sure that the phone wasn’t confused about which audio device I was expecting to be using. I figured it was going to be a dead duck but I would give it a try and guess what, it worked.

It would seem that the phone got itself into a weird state where it thought a set of headphones was connected even though there was not, perhaps something as silly as dust blocking up the audio jack contacts. As such, it was trying to direct the audio for the call down the 3.5mm headphone jack to a set of connected headphones and not into the internal speaker. Popping a headphone connector in and out of the jack seems to have reset it and restored order to the force.

Hope this helps something else out there with a similar problem.